sábado, 12 de maio de 2018

Pg_restore Unsupported Version in File Header

Olá galera,

No post de hoje, vou relatar um problema encontrado devido a diferença entre versões do PostgreSQL.

Ao gerar o backup utilizando o pg_dump e tentar restaurar com pg_restore em uma versão mais nova do PostgreSQL, obtive a seguinte mensagem de erro:

pg_restore: [archiver] unsupported version (1.13) in file header

Para resolver o problema, vamos executar o comando abaixo na máquina que geramos o .backup.

pg_restore -Fc meu_arquivo.backup -f meu_arquivo.sql

Agora vamos copiar o meu_arquivo.sql para a máquina onde o problema ocorreu e queremos restaurar o backup. Em seguida, executaremos o comando abaixo:

psql meu_banco -f meu_arquivo.sql

Uma dica bem simples mas bastante útil para resolver o problema.

Um forte abraço e até a próxima.

Nenhum comentário:

Postar um comentário